ошибка при установке ipb 3.4.9

Patrick

Случайный прохожий
Пытаюсь поставить на localhost форумный движок invision power board 3.4.9 и сразу ловлю ошибку
Код:
[B]Fatal error[/B]: Uncaught Error: Call to undefined function set_magic_quotes_runtime() in C:\xampp\htdocs\initdata.php:394 Stack trace: #0 C:\xampp\htdocs\index.php(21): require_once() #1 {main} thrown in [B]C:\xampp\htdocs\initdata.php[/B] on line [B]394[/B]
Подскажите как установить IPB ?
PS с ним никогда не сталкивался и не знаком:dummy:
 

Julia

Случайный прохожий
Пишут что из за устаревшей функции php. Какая у вас версия используется?
Попробуйте открыть файл /initdata.php

найдите
Код:
 @set_magic_quotes_runtime(0);  if ( ! defined( 'IPS_MAGIC_QUOTES' ) ) {     define( 'IPS_MAGIC_QUOTES', @get_magic_quotes_gpc() ); }
и замените на

Код:
 if( version_compare( phpversion(), '5.4.0', '<') ) {     @set_magic_quotes_runtime(0);      if ( ! defined( 'IPS_MAGIC_QUOTES' ) )     {         define( 'IPS_MAGIC_QUOTES', @get_magic_quotes_gpc() );     } } else {     if ( ! defined( 'IPS_MAGIC_QUOTES' ) )     {         define( 'IPS_MAGIC_QUOTES', false );     } }
 

Patrick

Случайный прохожий
Спасибо. С этим разобрался.
Еще вопрос. Поставил шаблон темы для IPB но в footer вижу такую надпись:
[[Template core/front/global/footer is throwing an error. This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.]]
 

BageeRa

Случайный прохожий
Тема предназначена для другой версии IPB или тема устарела:crazy_pilot:
 
Верх Низ