отчеты из 1с в pdf

Lera

Участник
Доброго времени суток, ув. форумчане подскажите как можно формировать отчеты из 1с предприятия 8.3 в формате PDF ?
Пока на ум приходит использование виртуального PDF принтера (типа Bullzip PDF printer или PDF creator)..
 
Диадок

Lehhaa

Случайный прохожий
Либо использовать виртуальный принтер для пакетного вывода из 1с
Код:
//упрощенная процедура для формирования ПДФ
Процедура ПолучитьФайлПДФ(Таб,ИмяФайла)
   принтер=Новый ComObject("Bullzip.PDFPrinterSettings");
   принтер.SetValue("output", ИмяФайла);
   принтер.SetValue("ShowSaveAS", "never");
   принтер.SetValue("ShowProgress", "no");
   принтер.SetValue("ShowProgressFinished", "no");
   принтер.SetValue("ShowSettings", "never");
   принтер.SetValue("ShowPDF", "no");
   принтер.SetValue("ConfirmOverwrite","no");
   принтер.SetValue("OwnerPassword","Pass4PDF");
   принтер.SetValue("Permissions",61636);
   принтер.WriteSettings();
   Таб.Автомасштаб=Истина;
   Таб.Имяпринтера="Bullzip PDF Printer";
   PDFФайл = Новый Файл(ИмяФайла);
   Если НЕ PDFФайл.Существует() Тогда
      Таб.Напечатать(Истина);
       Пока НЕ PDFФайл.Существует() Цикл
         ОбработкаПрерыванияПользователя();
         ТаймерЗадержки;
      КонецЦикла;
   КонецЕсли;
КонецПроцедуры
 
Верх Низ