Ошибка окрытия параметров почты OWA

Anonser

Почетный гость
При открытии параметров почты OWA в результате перехода по ссылке с портала возникает ошибка. Только через Chrome и если стоит параметр - открывать в новой вкладке. Выдаёт ошибку примерно следующего содержания
Error at Function.ErrorHandling.$EM Uncaught// SecurityError: Blocked a frame with origin from accessing a cross-origin frame.
В чём может быть проблема? Проблемы интеграции OWA с сайтом или всё же какая-то проблема с Chrome?
 
Последнее редактирование модератором:

Surf_rider

Администратор
Команда форума
браузеры блокируют скрипты, которые пытаются получить доступ к iframe с другим источником.
 

awocose

Случайный прохожий
Вот здесь обсуждали, вообще говорят нельзя так
Так как страница, которая загружается во фрейме, находится на другом домене, то у вас нет прав для доступа и редактирования этой страницы.
Что бы была возможность редактировать страница, которая загружает фрейм, и которая загружается во фрейме, должны быть на одном домене. Иначе нужно проксировать через свой сервер и домен, вот одна из статей как такое делать
 

SvetlanaD

Участник
Кстати вопрос - ошибка возникает во всех браузерах или только в хроме ? Что будет если через internet explorer:unsure:
 

NanoSuit

Участник
В хроме нет ли никаких дополнений и адд онов ?
Похоже что дело в настройках хрома
 

Anonser

Почетный гость
В хроме нет ли никаких дополнений и адд онов ?
Похоже что дело в настройках хрома
Стоит защита от фишинга и прочего... да и собственно всё. Сильно в настройках браузера ничего не менялось, кроме панели уведомлений.
 

deadushka

Участник
А как они авторизуются когда переходят в owa ? Я имею в виду что https:\\mailserver\owa и при переходе по ссылке из портала они пароль вводят ? Юзер в портале - уже авторизован так ?
 

deadushka

Участник
Возможно хром не проглатывает NTLM аутентификацию, подозреваю что именно она используется
 
Верх Низ